Excessive Memory and CPU use in Copernic Desktop Search

Posted about 4 years ago by Edwin Courts

Post a topic
Edwin Courts

 During the last week I am experiencing excessive CPU and memory use from the Copernic Plugins service (Copernic.Plugins.PluginsService.exe - V7.1.2.13483). It commands up to or more of 50% of CPU, rises above 24.5GB of private bytes of memory with a 10.5GB working set (16GB physical memory, Windows 10, Intel i7 CPU. Windows is unsuccessfully trying to recover memory as the process is continually in contention with the Memory Compression agent.  In effect Copernic is swamping my PC

I've wound down indexing performance to "restricted" and re-started/rebooted but it makes no difference.

The main index is essentially complete and only being updated (currently 757,847 indexed documents)

A PC reboot is a temporary fix, but after 5-6 hours the problem returns.

Does anyone have an idea what might be causing this, or how to fix it?

0 Votes


Sorted by

Noel Ferguson posted almost 2 years ago

This problem is reported as "solved" I am still having the same problem 2 years later.

0 Votes


Jörg Sams posted over 2 years ago

I am as well observing massive CPU usage Problems on an i7/16GB PC (Copernic Plugins Service ).  Is there a solution to this problem yet? So far I have to quit the program and restart it if I want to use it.

0 Votes


Stuart Cox posted over 2 years ago

This is also happening on my computer. Copernic Plugins Service at 94.9% cpu with initial indexing at 99% during the index recreation due to Copernic's recent update to its index structure.  Indexing has remained at 99% for several days.  Would like the indexing to complete in the foreseeable future.

0 Votes


Edwin Courts posted over 3 years ago

When this happened to me and the support looked deeper into it, the plugin service was somewhat overwhelmed b a very complex PDF file  which came from AutoCAD data and had more than 100,000 vector elements which were being processed by Copernic. It took over 7 hours to scan on an empty (and powerful) PC. Once the scan was completed everything returned to normal. I felt it was a bit crazy to scan vector CAD data at all, as there was effectively nothing of value to index that cold be later searched, but that's the way it worked.

0 Votes


Mirco Persechino posted over 3 years ago

Hi  Gerhard ,

We created a support ticket for you in order to investigate this issue with you as this is unusual. We'll be in touch shortly.


0 Votes


Gerhard Waehling posted over 3 years ago

It seems I ran into the same problem.
Copernic.Plugins.PluginsService.exe took app. 22 GB memory and 10 GB  working memory.
Physical memory is 16 GB and an SSD as storage place.
CDS.exe takes round about 1 GB (varying between 0.5 GB to 0.75 GB.
The search results are presented slowly, the first opened document is fixed. No other document can be opened, while folder may be opened or not or the folder related to the first document is opened.
The index has stopped 3 hours ago, from the time it may be finished.
Computer switch on time today:  app. 5 hours

Countermeasure in the moment: Restart the computer!! That is not real option.

0 Votes


Edwin Courts posted about 4 years ago

Copernic support have helped me to pin this down to a large (20Mb) granulated PDF file in a Dropbox folder that is being indexed (you can check this by selecting "View"-"Indexing Status" in the main CDS window. What is not clear is why a 20MEGAbyte file should required a (currently) 20 GIGAbyte process memory (working set) to process, and why that memory is not released once the file indexing is complete (it took about 3 hours).

0 Votes


David Levy posted about 4 years ago

I am having the same problem so I am interested in a possible solution.

0 Votes

Login or Sign up to post a comment